All of our servers run PHP 5.2.x, Perl 5.10.x & MySQL 5.0.x or above. If you need to be hosted on a server with a specific version (e.g. PHP 5.3.x), please let us know.

SSL certificates provide essential security. Without one, your site will be marked as insecure by the major browsers and penalised by search engines.

Enjoy 1-click WordPress installation, easy updates, patching, integrated security tools and simple, multisite site management, all through our easy to use WordPress Toolkit.

 

For specific information on Softaculous apps and Cpanel tools, please click this link or browse the menu for Hosting Information.

Tags: website hosting, hosting iinformation, server information, wordpress, joomla

Created & Designed by Zetec X